Payment platform temporarily unavailable - 04.02.2026 since 10:42 AM (UTC)

Incident Report for Payrexx

Resolved

The problem has been identified and resolved. The platform has been fully accessible again since 11:12 AM (UTC).
Posted Feb 04, 2026 - 11:41 UTC

Identified

We are currently experiencing a temporary service interruption on the Payrexx platform due to a system update. Our IT team is actively working on resolving the issue as quickly as possible.
Posted Feb 04, 2026 - 11:34 UTC
This incident affected: Payment Platform (Payrexx Payment, Payment Adapters).